Site is experiencing degraded performance, team is investigating.
Incident Report for magiceden
Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 18:11 PDT
Update
We are continuing to investigate this issue.
Posted Jul 22, 2022 - 18:10 PDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2022 - 17:00 PDT
This incident affected: MagicEden.io Website and MagicEden API.