Solana network is slow, RPC providers are experiencing high latency

Incident Report for magiceden

Resolved

Solana network is still slow, but the RPC provide issue is fixed.
Posted Apr 06, 2022 - 09:41 PDT

Investigating

We are currently investigating this issue.
Posted Apr 06, 2022 - 09:24 PDT
This incident affected: Solana Dedicated RPC.