Degraded performance due to high volume of traffic
Incident Report for magiceden
Resolved
This incident has been resolved.
Posted May 27, 2022 - 12:56 PDT
Update
We are continuing to investigate this issue.
Posted May 27, 2022 - 12:54 PDT
Investigating
We are currently investigating this issue.
Posted May 27, 2022 - 11:54 PDT
This incident affected: MagicEden.io Website and MagicEden API.